Playlists suddenly showing 0 tracks, but songs, albums, artists are ok

Post Reply
denogginizer
Posts: 1
Joined: Thu Dec 10, 2020 9:00 pm

Playlists suddenly showing 0 tracks, but songs, albums, artists are ok

Post by denogginizer »

MyMedia has been running in docker for a few months with no problems (I think this is my 3rd year as a client). I love it.
Recently, playlists (without changing anything) are showing as having zero tracks.

What I've tried:
- Restarted the container
- Rebuilt the container
- Rechecked the m3u8 files
- Checked permissions (users:me 0777)

I've spent quite a few hours trying to get this back as I use it everyday.
Hopefully, you can help!
Thanks

Edit:

Watch Folder Scan Results
=========================
Path: /medialibrary
Scan start time: 12/11/2020 17:44:38

Filescan Returned: 4213 files
Success: /medialibrary/Everything/01 - (Don't Fear) The Reaper.mp3
{snip}
Success: /medialibrary/Everything/86 - American Woman (7 Version).mp3
Processing playlist - /medialibrary/Everything/everything.m3u8
Playlist Name: everything
Playlist Trackcount: 0
Complete
Success: /medialibrary/Everything/everything.m3u8
Scan end time: 12/11/2020 17:44:52
dbinder101
Posts: 8
Joined: Tue Oct 02, 2018 4:14 pm

Re: Playlists suddenly showing 0 tracks, but songs, albums, artists are ok

Post by dbinder101 »

I am having the exact same problem! I don't know if started when I upgraded to the latest version (1.3.140 on raspberry pi) or before. It picks up all the playlist names but all of them show as 0 tracks. Please look into this. Thank you.
audio_inside
Posts: 6
Joined: Tue Jan 05, 2021 5:38 am

Re: Playlists suddenly showing 0 tracks, but songs, albums, artists are ok

Post by audio_inside »

I'm also getting zero tracks showing in the .m3u8 files that I export from iTunes to my docker instance of My Media, even though the file shows up in Playlists section of the Console.

Not having used .m3u8 files before I suspected user error (there's a hard path to the iTunes Music file encoded in the .m3u8 file, can that be right?) and tried manipulating the entries to get My Media to recognize them, to no avail.

Discovered this thread while searching for a fix, so it sounds like even if I had the correct playlist file format there might be other system issues preventing exported .m3u8 files from playing back correctly. :cry:
Attachments
image.png
image.png (771 Bytes) Viewed 176 times
bizmodeller
Posts: 443
Joined: Thu Nov 14, 2013 8:40 pm

Re: Playlists suddenly showing 0 tracks, but songs, albums, artists are ok

Post by bizmodeller »

Hi,

this was a bug that creeped into 1.3.136.0. It has been resolved in 1.3.141.0 which is the #latest docker tagged version,

thanks and apologies for the inconvenience
User avatar
Jaffo
Posts: 24
Joined: Fri May 15, 2020 11:31 pm

Re: Playlists suddenly showing 0 tracks, but songs, albums, artists are ok

Post by Jaffo »

He's alive! :D
San Holo 1
Posts: 2
Joined: Fri Jan 15, 2021 8:07 pm

Re: Playlists suddenly showing 0 tracks, but songs, albums, artists are ok

Post by San Holo 1 »

Hi I'm new to the forum

Ive got an Alexa and wanted to know if I'm doing something wrong regarding my iTunes smart playlists.

Ive downloaded the app and given Alexa the skill but all my smart playlists are showing 0 tracks

Ive even downloaded the beta version which i saw in this thread cured the problem.

do i have to rest anything to get it working or should it work if I just re index the watched folders

Thanks

San Holo 1
San Holo 1
Posts: 2
Joined: Fri Jan 15, 2021 8:07 pm

Re: Playlists suddenly showing 0 tracks, but songs, albums, artists are ok

Post by San Holo 1 »

Cured my playlist problem , thanks for the prompt reply on the email system.

I have now put iTunes and my Itunes media folder on the same drive.

BTW smart playlists in iTunes are picked up when indexed by My Media App runs

All good in my world :D :D :D :D :lol:
Post Reply