WebUI on Windows Phone

Post Reply
netquick
Posts: 2
Joined: Mon Jan 12, 2015 9:56 am

WebUI on Windows Phone

Post by netquick »

I installed ihomeserver for testing purposes and I am pleased with it so far. Unfortunately I cannot access the WebUI through my Windows Phone. When I try to open the Webpage it's only loading, the Message "loading ihomeserver" is and stays visible but the page don't load.
I tried to search for a solution but since both "Windows" and "Phone" are too common terms to search for I was not successful.

The page is loading correctly when using my desktop pc or an iOS device. Only WP8.1 has troubles loading the page. Is there something I can try? I am not sure but it seems WP is not supported so far. I am really interested in licensing ihomeserver but when I cannot use it on my primary mobile device I am stuck with it.

Any help is appreciated.
Kind regards
netquick
bizmodeller
Posts: 443
Joined: Thu Nov 14, 2013 8:40 pm

Re: WebUI on Windows Phone

Post by bizmodeller »

We have tested the iHomeServer iTunes web interface on Windows Phone 8.1 and it is working for our test devices. So it should work ok.

One thing I can think of is to check in Internet Explorer settings whether you have the checkbox "Allow sites to store files on my phone" ticked? We use HTML5 caching to speed up page loading so it may break if this is unticked.
netquick
Posts: 2
Joined: Mon Jan 12, 2015 9:56 am

Re: WebUI on Windows Phone

Post by netquick »

Thanks for your reply. I already checked this and tested different settings. Doesn't make a difference. My phone is developer unlocked. So I cannot tell if it would work otherwise but afaik there's currently no difference. I will test on another WP Device this evening. It already helps to know that you have tested and it should work.

Greetings
bizmodeller
Posts: 443
Joined: Thu Nov 14, 2013 8:40 pm

Re: WebUI on Windows Phone

Post by bizmodeller »

Ok - we've retested this on quite a few devices and we are seeing some Windows 8.1 devices not rendering the interface. Oddly the MS emulator works perfectly.

So just a quick update to say we're looking into this and hopefully will have some more news in a few days...... thanks
bizmodeller
Posts: 443
Joined: Thu Nov 14, 2013 8:40 pm

Re: WebUI on Windows Phone

Post by bizmodeller »

This is now resolved in iHomeServer 3.1.75.0 which is available as a pre-release / beta version at the bottom of our downloads page - http://www.bizmodeller.com/ihomeserver/ ... nload.aspx

please let us know if this resolves your issue and apologies for the inconvenience (which was caused by the introduction of a Windows Phone 8.1 update)
bizmodeller
Posts: 443
Joined: Thu Nov 14, 2013 8:40 pm

Re: WebUI on Windows Phone

Post by bizmodeller »

BTW - you may need to clear your browser cache in order to see the new version (depending on browser)
Post Reply