When I request music via My Media, I just get silence

Post Reply
bizmodeller
Posts: 442
Joined: Thu Nov 14, 2013 8:40 pm

When I request music via My Media, I just get silence

Post by bizmodeller »

For most users, My Media for Alexa just works - you complete the installation steps, ask for your music and it plays.

However, some users experience issues getting any music to sound - oftentimes, your Alexa will acknowledge the request (eg "Playing music from your My Media collection") and then ..... silence.

The reasons for these can be varied so this topic acts as a knowledge base for helping to understand the reasons for this. The list of reasons is listed in order of most frequent to rarest (approximately!)

1. Firewall installed on the computer running My Media

My Media for Alexa tries to stream your media directly within your local network. This has many advantages to streaming over the internet - you save bandwidth, latency is lower, you don't have to open ports up to the internet, etc. However, to make this happen, your Alexa device needs to be able to connect into the computer running My Media. If you have a software firewall installed, it might be necessary to open a port on the software firewall to let your Alexa devices connect in.

Specifically, you need to open TCP port 52050 - this is the port that My Media uses to stream music. If you are running Windows Firewall (the default firewall installed with Windows) then the My Media installation program will automatically create the necessary rule to allow this traffic into your computer from your local network. However, if you are using third party firewalls such as McAfee, Norton, etc, you may need to manually create the rule using the instructions relevant to your firewall provider. We have provided some help guides on our website for some common firewall products:

Norton - see https://www.mymediaalexa.com/home/mymedia_norton

Avast - see https://www.mymediaalexa.com/home/mymedia_avast

McAfee - see https://service.mcafee.com/webcenter/po ... xxoqtlq_49

Remember when creating your rule, you only need to allow INBOUND access to port 52050 for TCP traffic from your local network. And remember this is on your computer's firewall - My Media does not require you to open any ports on your internet router for normal operation.

The easiest way to test whether you have this issue is to temporarily disable your firewall and test My Media again. If it works it's definitely a firewall configuration issue and should be easy to fix!

2. Computer running My Media is on a different network to the Alexa device

The second reason Alexa can't stream media is because your Alexa devices and My Media server may be on different networks without a route between the two. For example, if you have a guest wifi set up which is independent of your wired ethernet network then if your Alexa device is on guest wifi and the My Media server is on your wired ethernet, it's unlikely Alexa can stream the media because it can't connect to the private IP address of your computer. Instead, please ensure they are on the same network and share the same IP address subnet.

3. The Alexa device doesn't support streaming properly

Whilst the Echo / Dot / Show are the most recognizable Amazon Alexa devices, there are a multitude of third party manufacturers who are building their own smart speakers and embedding Alexa Voice Services into their firmware. We test My Media on Amazon devices, however, third party manufacturers may not honour the full Amazon spec or may have issues streaming local media that we have overcome with Amazon devices. In these cases, there's little that can be done as we don't have every single Alexa compatible device to test with. Best thing would be to email the technical support contact for your device and ask them what's up.

4. Invalid media

If Alexa tries to stream media but she can't process the media, she'll usually stay silent rather than giving a useful voice prompt. This can happen, for example, with M4A tracks which are encoded in alac format (Apple Lossless). If you're only getting issues playing alac files, then please install ffmpeg and configure it in My Media settings - this will enable transcoding support for these file formats and let the tracks play.

5. Unavailable media

By default, My Media scans your music library every 6 hours (although this can be disabled in Settings). If a track has been deleted, it will be removed from the library. However, if it's deleted after My Media has started playing a playlist that contains the track, playback may be impacted. In most cases, My Media will skip the missing track and play the next track, however, if too many tracks have been deleted, My Media will give up and stop playing the playlist.

6. VPN Software

If you are running VPN software and have an active VPN connection from your computer, it's quite likely that (a) it will change the primary IP address of your computer and (b) it may prevent dual access to your local network whilst the VPN is in place. Both will prevent My Media from streaming music to your Alexa devices because the VPN's IP address will not be contactable (routable) by your Alexa devices and if your VPN isolates your local network then it won't be able to access it anyway. If your router doesn't block access to your local network but only changes the IP address of your computer during the VPN session then you may be able to still enjoy My Media whilst connected to your VPN. You could try this by ensuring you have given your computer a static IP address on your local network and then set the IP address that My Media advertises to Alexa to this static IP address in the My Media Settings console. This will override My Media autodetecting the IP address and it will always advertise the right IP to your devices.

7. Running in Docker using NAT mode

If you are running My Media as a Docker container and using NAT networking mode, then the My Media instance will be running with its own private Docker-assigned IP address. Unfortunately the container has no idea what the actual IP address of the Docker host is (the one which is actually on the same network as your Alexa device). Therefore, you need to tell My Media what the Docker host's IP address is. First make sure your Docker host (eg your NAS) has a static IP address - so it doesn't change. Then log into the My Media web console, click Settings, and enter the static IP address into the 'Listening IP address' field on the page. This will then ensure that My Media advertises the right IP address to your Alexa device.

8. Guest wifi networks

If your Alexa device is on your guest wifi but your My Media computer is on your normal wifi, the two wifi networks will not be able to talk to each other as your guest wifi is segregated from your home network. To resolve this, move your Alexa onto your normal home network.

9. Wifi networks with guest isolation

Some wifi routers have an option to isolate network access for different guests. It is very unusual for this to be enabled by default, but is reasonably common to have as an option to select within the router configuration. This setting would allow all wifi connected devices to access the internet, but would prevent devices from talking to each other - this would also prevent Alexa from talking to the My Media server app. To resolve this, disable network isolation on your wifi router.

10. You are using the Windows 10 Alexa App and trying to stream music from My Media running on the same computer

This is blocked by default due to loopback isolation that is configured on all Windows store app. Please see this forum post for a possible workaround - viewtopic.php?f=15&t=23251.

If we think of any others we'll add them to the list above in due course.

thanks
richaardvark
Posts: 6
Joined: Sun Sep 02, 2018 6:32 am

Re: When I request music via My Media, I just get silence

Post by richaardvark »

If you are running Windows Firewall (the default firewall installed with Windows) then the My Media installation program will automatically create the necessary rule to allow this traffic into your computer from your local network.
Can you please make available a manual override somewhere in the settings to allow the My Media server to automatically complete this automatic port-opening process again, on-demand? Thanks!
bizmodeller
Posts: 442
Joined: Thu Nov 14, 2013 8:40 pm

Re: When I request music via My Media, I just get silence

Post by bizmodeller »

richaardvark wrote:
Mon Sep 10, 2018 11:00 am
If you are running Windows Firewall (the default firewall installed with Windows) then the My Media installation program will automatically create the necessary rule to allow this traffic into your computer from your local network.
Can you please make available a manual override somewhere in the settings to allow the My Media server to automatically complete this automatic port-opening process again, on-demand? Thanks!
Uninstall and reinstall is the easiest way to recreate the default My Media rules - this will only work with Windows firewalls though. Your configuration is saved so you won't have to set everything up again.
CarsmileSmith
Posts: 1
Joined: Sun Dec 23, 2018 6:03 pm

Re: When I request music via My Media, I just get silence

Post by CarsmileSmith »

I resolved this problem by *not* using the "guest" wi-fi access.

Once I set Alexa to my "main" wi-fi access point, all was well.
bizmodeller
Posts: 442
Joined: Thu Nov 14, 2013 8:40 pm

Re: When I request music via My Media, I just get silence

Post by bizmodeller »

FYI above post has been updated since finding another known reason for this - Windows 10 loopback disabling for the Windows 10 Alexa app.
SHEILACLARK00
Posts: 2
Joined: Sun Oct 11, 2020 12:02 pm

Re: When I request music via My Media, I just get silence

Post by SHEILACLARK00 »

bizmodeller wrote:
Sun Jul 26, 2020 2:43 pm
FYI above post has been updated since finding another known reason for this - Windows 10 loopback disabling for the Windows 10 Alexa app.
I have only recently had this problem. If I turn off the Windows Defender Firewall under Private Network Settings, then the music will play. I do not really want to turn the firewall off. I have tried adding the MyMedia app to the "allowed apps", but this does not resolve the silence problem. (MEDIA_ERROR_UNKNOWN)

What can I do? Any advice would be greatly appreciated.
bizmodeller
Posts: 442
Joined: Thu Nov 14, 2013 8:40 pm

Re: When I request music via My Media, I just get silence

Post by bizmodeller »

Hi,

If you are using Windows Firewall and the firewall rules are missing, please just reinstall My Media as this will recreate the firewall entries (and you won't lose your settings in the app).

If this still doesn't work then you need to create a port forwarding rule for TCP port 52050 and this has to be done against your computer, not a specific application (i.e. it cannot be an application rule). This because we use the native http stack within Windows which is actually owned by the OS rather than our app therefore the firewall rule can't be an application rule. On most firewalls this is called a 'packet rule' instead of an application rule.
SHEILACLARK00
Posts: 2
Joined: Sun Oct 11, 2020 12:02 pm

Re: When I request music via My Media, I just get silence

Post by SHEILACLARK00 »

bizmodeller wrote:
Sun Oct 11, 2020 3:42 pm
Hi,

If you are using Windows Firewall and the firewall rules are missing, please just reinstall My Media as this will recreate the firewall entries (and you won't lose your settings in the app).

If this still doesn't work then you need to create a port forwarding rule for TCP port 52050 and this has to be done against your computer, not a specific application (i.e. it cannot be an application rule). This because we use the native http stack within Windows which is actually owned by the OS rather than our app therefore the firewall rule can't be an application rule. On most firewalls this is called a 'packet rule' instead of an application rule.
Thank you. I was worried that I would have to re-do all the music again, but the uninstall/reinstall was simple and everything was still there!

Working perfectly now - Hoorah!!!
Post Reply