Alexa plays .mp3 files but .M4A files cause ERRORs- SOLVED

Post Reply
Ed D.
Posts: 1
Joined: Tue Jan 17, 2023 11:55 pm

Alexa plays .mp3 files but .M4A files cause ERRORs- SOLVED

Post by Ed D. »

When asked to play music from mymedia ("MM") Alexa announces the song and plays it if it is an MP3 file. When asked to play an M4A format song, Alexa announces the song but it doesn't play. The MM console indicates an Error:

Your Alexa device reported an error streaming the current track (E:\My Music\iTunes\iTunes Media\Compilations\The Very Best of Cream\01 Wrapping Paper 1.m4a).

The detailed message was: Device playback error.

The playing device is an Amazon Dot. I only have one itunes/ MM library, it was indexed successfully, all songs are in the same library and iTunes can play the M4A tracks without issue. I have also installed and enabled the ffmpeg transcoder but this did not fix the problem. (The files that won't play are likely all in Apple ALAC format.)

The message appears to indicate that it is the Alexa device (in this case, an Echo Dot) that has a "playback error."

SOLUTION: I had to change the transcoder bitrate manually in the settings from its default value of 160 kbps to 192 kbps.

Please note that from the time I initially wrote to the time that I figured it out myself (five days? six days?) the moderator never got around to posting this! It still isn't posted at this time!

No help, no response to questions, can't even post my question. It looks like nobody's driving the bus!
Post Reply