iHomeServer not working with ESET Smart Security F/W (FIXED)

Post Reply
MK_Slinky
Posts: 8
Joined: Sat May 24, 2014 4:50 pm

iHomeServer not working with ESET Smart Security F/W (FIXED)

Post by MK_Slinky » Sun May 25, 2014 12:04 am

iHome Server installed on Windows 7 desktop PC and running in desktop mode.

I can play iTunes ok in my local web browser (firefox) however this does not work when trying to access iTunes on my laptop PC. The connection simply times out!

Likewise when trying to access iTunes via a web browser on my Android device (Orange San Francisco running Gingerbread) it fails to connect.

I am also experiencing much the same problem with my DLNA certified Sony STR DN-1040 AV Receiver. It can see the iHome Server and I can browse all folders within iTunes but none of my tracks can be played. The receiver does try to play them but fails every time.

I have the exact same issue on my WD TV Live Media Player, all tracks are visible within iTunes but cannot be played!

I really want this software to work but for me it's really buggy!

Can someone help please...
bizmodeller
Posts: 365
Joined: Thu Nov 14, 2013 8:40 pm

Re: iHome Server Not working on most device..

Post by bizmodeller » Sun May 25, 2014 5:25 am

This sounds like a firewall issue on the Win 7 machine given that you can access the web interface locally ok. The DLNA service also uses the web interface to stream media which is why you are getting the same symptoms on both web and DLNA devices.

As a quick test can you disable the firewall on your Win 7 machine and see whether that resolves the issue. If it confirms the issue is the firewall, then we can check what's happening - the iHomeServer installer should create a firewall rule to allow the web access to work.

Three other bits of information would be very useful:

1. Which version of Windows 7 are you using - 32-bit or 64-bit?
2. Which software firewall product are you running - just Windows built-in, or do you have a McAfee or other firewall installed?
3. Have you changed the default web port for iHomeServer which is 42050?

Thanks
MK_Slinky
Posts: 8
Joined: Sat May 24, 2014 4:50 pm

Re: iHome Server Not working on most device..

Post by MK_Slinky » Sun May 25, 2014 2:04 pm

Hi Guys,

Thanks for the reply. :)

I'm not able to test the firewall theory right now but will do later this evening.

To answer your other questions..

1. Which version of Windows 7 are you using - 32-bit or 64-bit? I'm using W7 - 32 Bit (I have installed the correct version)

2. Which software firewall product are you running - just Windows built-in, or do you have a McAfee or other firewall installed? I am using ESET Smart Security 6 (fully up-to-date)

3. Have you changed the default web port for iHomeServer which is 42050? No

Cheers :)
MK_Slinky
Posts: 8
Joined: Sat May 24, 2014 4:50 pm

Re: iHome Server Not working on most device..

Post by MK_Slinky » Mon May 26, 2014 3:50 am

Hi guy's,

A quick update on previous events...

I have this evening rolled back my system using Norton Ghost and reinstalled iHomeServer only this time I disabled my ESET Smart Security Firewall beforehand. In addition I have elected to have iHomeServer run iTunes as a Windows Service.

Installation went as expected and after accessing iHomeServer via my Sony STR DN-1040 AV Receiver I was finally able to play my Itunes content. Although not very exciting to look at, just a black screen with a list of music it does finally work. Here's a screen shot of it in action playing one of those tracks on my Sony Viera TV.
IMG_20140525_222341.jpg
IMG_20140525_222341.jpg (172.06 KiB) Viewed 8964 times
HOWEVER...!!!!

I re-enabled ESET Smart Security Firewall and immediately lost connection to iTunes via my receiver and my music ceased playing. :(( I have reproduced this error twice more and so as previously mentioned by 'bizmodeller', this does appear to be a firewall issue. Furthermore, I have checked the various settings within the ESET Firewall and can find no entries relating to iHomeServer..., hmmm!

Although I haven't been able to do further tests (it's 04:45am)!! I have just installed the latest release of ESET Smart Security 7 which I am hoping may have solved this issue. I will report back later today.

Falling asleep here now ZZZzzzzzzzzzzzzzzz
Last edited by MK_Slinky on Tue May 27, 2014 1:30 am, edited 1 time in total.
bizmodeller
Posts: 365
Joined: Thu Nov 14, 2013 8:40 pm

Re: iHome Server Not working on most device..

Post by bizmodeller » Mon May 26, 2014 9:39 am

Glad you've made some progress!

To be honest, I'm not sure the update of the firewall software will help. The iHomeServer installer opens the required ports in the Windows standard firewall on the machine. This may not work with third party firewall software unless they have hooked into the standard Windows APIs (which most don't I'm afraid) - this will probably be the case with any other server software you want to install.

I do not have a copy of ESET Firewall to test, however, you will need to create two inbound firewall rules to get this working.

Web / DLNA access requires TCP port 42050 inbound from your local subnet to the computer running iHomeServer
StreamMyiTunes internet access requires TCP port 42052 inbound from the Internet to the computer running iHomeServer

I struggled to find particularly useful information on the ESET website, however I did find the following knowledge base article for a previous version of ESET which walks through creating a rule - http://kb.eset.com/esetkb/index?page=co ... d=SOLN2149 - although you are running version 7, I would hope the interface was pretty similar.

Let me know how you get on
MK_Slinky
Posts: 8
Joined: Sat May 24, 2014 4:50 pm

Re: iHome Server Not working on most device..

Post by MK_Slinky » Mon May 26, 2014 2:40 pm

Hi bizmodeller,

Well there's something to be said for your quick response to my technical queries., don't you get any time off? :shock: I really appreciate you answering my questions so quickly! :D

Okay so I'm skipping doing a test with my new firewall update and have gone straight to creating a 'New Rule', thanks for the link! :P Here's a more up-to-date KB article for ESET Smart Security 7 if anyone is having the same troubles: http://kb.eset.com/esetkb/index?page=co ... d=SOLN3112

Here's some screen shots of the two 'New Rules' mentioned above..., hopefully I've done them right?!
iHomeServer.png
iHomeServer.png (25.06 KiB) Viewed 8974 times
StreamMyiTunes.png
StreamMyiTunes.png (28.21 KiB) Viewed 8974 times
One further question to 'bizmodeller'.., in the above screenhots at the bottom of each image it says "Application: For Every" Should I have selected the actual program name instead?????

Thanks again for your assistance, 'TOP MARKS' for Customer Service :D
bizmodeller
Posts: 365
Joined: Thu Nov 14, 2013 8:40 pm

Re: iHome Server Not working on most device..

Post by bizmodeller » Mon May 26, 2014 5:59 pm

These settings look good to me.
One further question to 'bizmodeller'.., in the above screenhots at the bottom of each image it says "Application: For Every" Should I have selected the actual program name instead?????
It should work fine with "Application: For Every", however, you could set it to the iHomeServer.exe program name if you prefer to make the rule more specific. The full path will be "c:\program files\iHomeServer\iHomeServer.exe"

Are you having more success with these rules in place?
MK_Slinky
Posts: 8
Joined: Sat May 24, 2014 4:50 pm

Re: iHome Server Not working on most device..

Post by MK_Slinky » Mon May 26, 2014 7:36 pm

SUCCESS!!!!!!!!!!!!!!!!!!!!!

Well I doubt I could have done it without your help.., thanks bizmodeller, you're a star! :D

DLNA Streaming is now working via my Sony AV Receiver and pleasuring my neigbours also :lol:

iTunes via my web browser is now also working on Big Dinky (my laptop)

No access via my Android phone but I think this is actually a limitation of the phone, i.e. browser not supported. (Not Important - I can live without that)!

Have yet to try via my WDTV Streaming Media Player but have every confidence. ;)

Re: Assigning the application to the rule.., in ESET Smart Security, the actual rules creator gives you the option to locate the actual 'EXE' file for said programme. That said I can find the iHomeServer.exe in 'Program Files' but I didn't notice the StreamMyiTunes.exe? Is it located somewhere else or does that executable file name not exist?

Thanks in advance.

Slinky
bizmodeller
Posts: 365
Joined: Thu Nov 14, 2013 8:40 pm

Re: iHome Server Not working on most device..

Post by bizmodeller » Mon May 26, 2014 8:50 pm

Great news - well done :D
Re: Assigning the application to the rule.., in ESET Smart Security, the actual rules creator gives you the option to locate the actual 'EXE' file for said programme. That said I can find the iHomeServer.exe in 'Program Files' but I didn't notice the StreamMyiTunes.exe? Is it located somewhere else or does that executable file name not exist?
iHomeServer.exe is the executable for both web streaming internally and web streaming via the www.StreamMyiTunes.com web site, so you should use the iHomeServer.exe executable in both cases

Best wishes
MK_Slinky
Posts: 8
Joined: Sat May 24, 2014 4:50 pm

Re: iHome Server Not working on most device..

Post by MK_Slinky » Tue May 27, 2014 1:03 am

Hi there,

Thanks for the update, I'll change both as instructed.

Cheers! ;)
Post Reply