Installing on Windows Server 2012 R2 Essentials

Post Reply
n0dyjeff
Posts: 3
Joined: Wed Jul 02, 2014 7:23 pm

Installing on Windows Server 2012 R2 Essentials

Post by n0dyjeff » Sun Jul 06, 2014 12:35 am

When installing iHomeServer onto Windows Server 2012 R2 Essentials, I ran into some problems when I got to the point where Service Credentials were required. I was trying to use a non-Administrator (Standard) user for the iTunes Service Credentials. No matter what I tried, I couldn't get past the Enter Service Credentials screen. I kept getting error messages implying that the account name or password was wrong - but it wasn't.

For those who may be experiencing the same problems, and don't want to use an Administrator account for the service credentials, here are the steps I followed that worked. My non-Administrator account was called iTunesUser.

1. Grant some privileges to the iTunesUser. In Local Security Policy, grant Log On As A Service and Allow log on through Remote Desktop Service.

2. In the Component Manager, go to the DCOM entry for APSDaemon.exe and give iTunesUser privileges for Activation and Launch. Same thing for iTunes. If you don't do this, you'll get messages in the Event log from the DCOM service griping about insufficient privilege.

3. Copy the iTunes subfolder under Music for iTunes user to the Music directory for your administrative account.

4. Use the administrative account to enter the iTunes Service Credentials when installing.

5. In the Services applet, change the log on credentials for the bizmodeller IHomeServer service to your non-administrative iTunesUser account and restart the service. Note that for some reason you can't do this within the Settings dialog of the iHomeServer plug in. I had to do it from the Services applet.

After this, everything works as advertised. Hope this helps.

Jeff
Post Reply