Partial library copying to itunes folder...

Post Reply
camasite
Posts: 2
Joined: Sun Oct 19, 2014 11:51 pm

Partial library copying to itunes folder...

Post by camasite » Mon Oct 20, 2014 12:03 am

I have been running iHomeServer (v. 2.2.36.0) on my WHS v1 for several years now. For various reasons, I decided to manually clean up my library and start from scratch. I deleted my iTunes folder and cleaned all the caches I could find. Opening iTunes presented me with an empty library. I then pointed the iHomeServer watch folder to my music library (\\HPEX490\Music), and told it to scan. For some reason, it is copying about 20% of my library into the iTunes folder, and then duplicating the links, so I get the same song linked once at \\HPEX490\iTunes\Music, and again at \\HPEX490\Music. I upgraded from iTunes 10.x to iTunes 11.1.5 (32-bit), but it does the same thing. I do NOT have either the "Keep iTunes Media folder organized" OR the "Copy files to iTunes Media folder when adding to library" boxes checked. Any ideas on how to solve this?
bizmodeller
Posts: 362
Joined: Thu Nov 14, 2013 8:40 pm

Re: Partial library copying to itunes folder...

Post by bizmodeller » Thu Oct 23, 2014 9:17 am

iHomeServer will not copy files across to the iTunes folder unless the checkbox 'Copy files to iTunes media folder' is ticked within iTunes itself, which you have confirmed is not the case.

The only other reason a file may get created in the iTunes library folder is if it has been converted by iTunes. Where you are getting duplicate links, what are the file types of those links, eg are they both MP3? Could you also let me know what file types you have listed for conversion under the 'Watch folder' tab of iHomeServer settings?

thanks
camasite
Posts: 2
Joined: Sun Oct 19, 2014 11:51 pm

Re: Partial library copying to itunes folder...

Post by camasite » Thu Oct 23, 2014 2:52 pm

Okay, it took a few days to get this topic approved, so I think I got it figured out in the meantime... there were two things happening concurrently that I was mistaking as one issue. The one that involved IHomeServer was that there were a handful of WMA discs that were being convereted to mp3, and these were showing up in the iTunes\iTunes Media\Music folder. I was not even aware that iTunes could convert WMA, and wasn't seeing the conversion being triggered when using the iHomesServer watch folder to import the library. I ended up seeing the dialogue box when I imported the library directly through iTunes, and was able to trace back the issue--turned out to be just a handful of soundtracks and compilations that my girlfriend had dumped into the network share, but iTunes broke them up into their individual artists, so it looked like a lot of music, but wasn't.

The second issue was that I had some legacy playlists inside of my network music share. This is where the real problem was--iTunes was reading the playlists, which were not using UNC pathways, and duplicating all the songs on the playlists, with one copy being d:\shares\music\... and the other being \\HPEX490\Music\... I cleared my library, deleted the playlists, and rescanned--no problems.

Thanks for the help, and hope this helps someone in the future.

P.S. Based on the response above, I also see that there is a tab within the iHomesServer settings that controls which files are automatically converted--I hadn't noticed that before, but good to know!
Post Reply