Issue with computer with multiple NICs

Post Reply
ericsten
Posts: 2
Joined: Mon Jan 18, 2016 1:46 am

Issue with computer with multiple NICs

Post by ericsten » Mon Jan 18, 2016 1:52 am

I have a Windows 2012 R2 server with two NICs, one for the network and one for NAS connectivity. I'm trying to use the StreamMyItunes feature but the software is binding to the NAS network card, not the actual "network" network card. Is there anyway to set iHomeServer to use a specific NIC?

Thanks

Eric Sten
bizmodeller
Posts: 245
Joined: Thu Nov 14, 2013 8:40 pm

Re: Issue with computer with multiple NICs

Post by bizmodeller » Mon Jan 18, 2016 8:46 pm

You should see that iHomeServer binds to all IP addresses on your server. However, some features such as DLNA and connection testing with Stream My iTunes may need you to specify which IP address is in use. You can tell iHomeServer which is your computer's primary IP address by creating the following registry key:

Folder: HKEY_LOCAL_MACHINE\SOFTWARE\bizmodeller\iHomeServer
Key (string) : WebListenerIPAddress

Please enter an IPv4 IP address and then restart the iHomeServer Windows service. Please then test local web access on your main IP address. If this doesn't work, then it may be a Windows/third party firewall issue on your server?

Let me know how you get on, thanks.
ericsten
Posts: 2
Joined: Mon Jan 18, 2016 1:46 am

Re: Issue with computer with multiple NICs

Post by ericsten » Thu Jan 21, 2016 8:08 pm

Well adding the registry key sorta worked. ;-) I added the key and the iHomeServer console displayed using the IP address I needed (192.168.0.25) but I still could not access any of the web interfaces provided on that address. They were all still bound to the second NIC IP (192.168.1.2), even after restarting the service and rebooting the system. So I could access the web interface for iHomeServer via 192.168.1.2:42051 but not 192.168.0.25:42051 even from the local system.

I WAS able to get it all to work by changing the ports that iHomeServer uses to different ports and the web services moved to the 192.168.0.25 IP address. So I am able to access everything through 192.168.0.25 using the new ports I selected. I was then able to NAT the IP/port from my router to the internal system and can stream videos remotely. :-)

So, I don't know why the web services would not bind to the other IP address until I changed the port but that is what did the trick after the reg change.

Thanks for your help!

Eric Sten
Post Reply